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The Contents lists Help topics available for Icon Vacuum.    Use the scroll bar to see entries 
not currently visible in the Help window.

To learn how to use Help, press F1 or choose Using Help from the Help menu
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 The Icon Vacuum Window

Click the part of the Icon Vacuum window you want to know more about.



 How to Register

To register this copy of Icon Vacuum, send $15 to:

Chris Nokleberg
4315 Norris Rd.
Fremont, CA    94536

You'll get the latest version, a registration number (for all future updates), and all the Visual 
Basic forms and code used to create this program. Please remember to include disk size, and
registration number is you already own a Herby Derby product.



 Viewing Icon Files

One of the main uses for Icon Vacuum is to keep track of all the icon files you may have 
floating around. These files usually have an *.ICO extension, but Icon Vacuum can view any 
icon files.

To view icons stored in a certain directory, simply use the directory and drive boxes to 
change to that directory. If the Auto-Refresh menu item is checked, Icon Vacuum will 
automatically update the view window. Otherwise, hit F5 or select Refresh Directory from the
File menu to manually update the view window.

See Also
Viewing Imbedded Icons
Changing the Icon Filter



 Viewing Icon Names

Simply move the mouse over any icon in the view window to display its name in the 
Directory/File Status Bar at the top of the screen.

Note: Because only icon files have names, if you are viewing icons within a file, that 
filename will appear in the Status Bar, not the name of the icon.

See Also
Changing the Icon Filter



 Changing the Icon Filter

To only display icons which match a certain filespec, or to view icon files with an extension 
other than *.ICO, you must change the icon filter.

First, either double-click the Directory/File Status Bar or choose Icon Filter... from the 
Options menu.

Input the new file specification. If you don't enter an extension, Icon Vacuum will 
assume a *.ICO extension.

If you enter an extension other than *.ICO, Icon Vacuum may take longer to update the view,
window, because it must check each file to see if it is an icon. Also, Icon Vacuum may 
mistake some bitmap pictures less than 770 bytes for icons, if they match the icon filter.

After choosing a new icon filter, Icon Vacuum will automatically update the view window if 
the "Auto-Refresh" setting is checked, otherwise you must press F5 to cause the view 
window to reflect changes to the icon filter. 

If the icon filter is something other than *.ICO, the new file specification will be displayed 
along with the directory in the Directory/File Status Bar.

See Also
Viewing Icon Names



 File Operations

Copying or Moving Icons

Select the Destination Directory
Select the icons you wish to copy or move and click the Copy or Move buttons or 

choose "Copy" or "Move" from the File menu.
Icon Vacuum will attempt to copy or move the selected icons. If an icon already 

exists, Icon Vacuum will ask you if you wish to overwrite it.
Icon Vacuum will automatically update the view window.

Deleting Icons

To delete an icon or icons, select the icons you wish to delete and click the Delete 
button or choose "Delete" from the File menu. 

Icon Vacuum will automatically update the view window.

Renaming an Icon

After selecting the icon you wish to rename, click the Rename button or choose 
"Rename" from the file menu, and input the new filename (must conform to DOS naming 
conventions).

Note: You may only rename one icon at a time. If you attempt to rename when more 
than one icon is selected, Icon Vacuum will not rename the icon.

See Also
Changing the Destination Directory
Selecting Icons



 Viewing Imbedded Icons

To view icons imbedded in a certain file, first use the directory and drive boxes to change to 
the directory where the icon is stored and then double-click on the file in the file list. Icon 
Vacuum will search through the file for any icons. Searching will take longer for large files. 
Once it is done, all the icons found will be shown in the view window.

Note: The default file specification for the file box is *.EXE, but you may select *.DLL or 
*.* if you wish to look at non-.EXE file.

If, for some reason, you wish to refresh the view window while displaying a file's imbedded 
icons, choose "Refresh File" from the File menu or press Shift-F5.

See Also
Imbedded Icon Searching Methods
Changing the Icon Filter
Viewing Icon Files



 "Vacuuming" Imbedded Icons

"Vacuuming" an imbedded icons will take the icon and write it to its own *.ICO file, which you
can then manipulate as you wish.

Note: Vacuuming in no way affects the source file whatsoever.

To vacuum an icon:

Select the Destination Directory (see below).
Select the icons you wish to vacuum and click the Vacuum button.

Icon Vacuum will vacuum the selected icons. The names Icon Vacuum assigns will be the 
first five letters of the file the icons are in followed by a three-digit number (i.e. 
001,019,234) and an .ICO extension. If an icon already has that number, Icon Vacuum will 
give the new icon the number immediately after.

See Also
Viewing Imbedded Icons
Selecting Icons



 Imbedded Icon Searching Methods

With Windows 3.1, users of Icon Vacuum have a choice of searching methods - "Find Less 
Icons Faster" and "Find More Icons Slower" in the Options menu:

"Find Less Icons Faster" finds and displays icons as fast or faster than viewing *.ICO 
files. For most files it usually finds all the icons, but for some types of programs, 
especially programs created with Visual Basic, it may only find one of 10 (worst-case 
scenario).

"Find More Icons Slower" uses a much slower technique (about 3 times slower) in its 
search for icons, but finds virtually all icons.

Windows 3.0 users can only use the "Find More Icons Slower" method.

See Also
Viewing Imbedded Icons



 Selecting Icons

Before you can do anything to an icon, whether it be deleting it, magnifying it, or copying it 
to the clipboard, you must first select it.

Selecting or Deselecting One Icon

To select or deselect one icon, simply click on the icon in the view window. The colors of 
the icon and its border will change to reflect the selection, as will the Icon Status Bar 
above the View Window.

Selecting or Deselecting Multiple Icons

To select or deselect a group of icons, sel. or desel. the first icon of the group by clicking 
it. Then, go to the last icon you want to sel. or desel. and click it while holding the SHIFT 
key. All icons in between will be selected or deselected, regardless of their previous state.

Selecting or Deselecting All Icons

If you wish to select or deselect all of the icons, simply click the appropriate button below
the view window. All icons, even those which are off the view window, will be selected or 
deselected.



 Icon Vacuum Revision History

Version 1.0 Released November, 1992
original version
written in Visual Basic 1.0, required VBRUN100.DLL

Version 1.5 Released January, 1993
current version
Windows 3.1 only
recompiled for Visual Basic 2.0, requires VBRUN200.DLL
loads and runs faster
online Windows help file
multiple magnification windows
deselection of multiple icons



 Changing the Destination Directory

The destination directory is the directory where icons are moved or copied to and where the 
icons created as a result of "vacuuming" are stored.

There are two ways to change the destination directory:

Click the        button after the destination directory input box or choose "Destination 
Directory..." from the Options menu. This will open up a dialog box in which you can 
change the drive and directory of the destination directory.

or
Type in the new destination directory in the destination directory input box in the top left 
corner of the Icon Vacuum window. If you enter a bad directory, Icon Vacuum will alert 
you and change the directory back to the original.

Until you change the destination directory, it will be the same as the directory you are 
currently viewing. Once you change the directory, though, it will stay the same until you 
erase the contents of the destination directory input box.

Note: If you wish to keep the same destination directory every time you use Icon 
Vacuum, type Control-D while the cursor is in the destination directory input box, or add 
"DesDir =" and then the path to the ICONVAC.INI file in your WINDOWS directory.

See Also
File Operations
The Icon Vacuum INI File



 Choosing and Running an Icon Editor

Choosing the Default Icon Editor

To input the path for the default icon editor, either choose "Default Icon Editor..." from 
the Options menu or click the      button next to the Icon Editor button.

Running an Icon Editor

When you click the Icon Editor button or choose "Icon Editor..." from the File menu, Icon 
Vacuum first copies the last icon you selected to the clipboard and then runs the Icon 
Editor that you've specified.
If you haven't specified an icon editor when you choose "Icon Editor...", or if the path or 
filename you've entered is incorrect, Icon Vacuum will ask you for the path of you icon 
editor before running it.



 The Initialization File: ICONVAC.INI

ICONVAC.INI, located in your WINDOWS directory, contains all user specification for Icon 
Vacuum.

Keyword Description Possible Settings
ViewWindowX Width of view window (measured in 

icons)
Minimum 5

ViewWindowY Height of view window Minimum 5
IconEditor Path of default icon editor Full path and filename
AlphaSort State of Alphabetical Sort menu item -1 (on) or 0 (off)
AutoRefresh State of Auto-Refresh menu item -1 (on) or 0 (off)
SearchFast Which search method Icon Vacuum 

uses
-1 (fast) or 0 (slow)

DesDir Path of static destination directory Full path
MaxIconNumber Maximum number of icons displayable 100-1000 (default 300)
RegName Registration name Only for registered users
RegNum Registration number Only for registered users

Destination Directory Input Box
You can enter a new destination directory by typing in this box. If you delete the contents
of the box, Icon Vacuum will change the destination directory to your current directory, 
and will update it when you change directories.

See Also
Changing the Destination Directory



Go To Destination Directory Button
Clicking this button will change the current directory to the destination directory. If 
Auto-Refresh is on, the view window will be automatically updated.

See Also
Changing the Destination Directory



Choose Destination Directory Button
Brings up the Destination Directory dialog box, which allows you to select a new 
destination directory graphically.

See Also
Changing the Destination Directory



Drive Selector
Lets you change the current drive. If Auto-Refresh is on, the view window will be 
automatically updated.



File Pattern Selector
This box has three choices    *.EXE, *.DLL, and *.*. Selecting one of these options will 
change the file list box to show only the files matching the pattern. Note: Does not affect
the display of icon file (i.e. ICO files), which is handled by the Icon Filter... menu item.

See Also
Changing the Icon Filter



Directory/File Status Bar
This status bar displays information about the icons you are currently viewing.
If you are viewing icon files (i.e. ICO files) then the status bar can display one of two 
things:

If the mouse is over an icon in the view window then the Directory/File Status Bar 
shows the name of the icons. 

If the mouse is not over an icon then the Directory/File Status Bar displays the 
directory the icons are located in (usually the current directory).

If you are viewing imbedded icons, the Directory/File Status Bar displays "Icons in" and 
the filename containing the icons.
Double-clicking the Directory/File Status Bar brings up the Icon Filter dialog box.



Icon Status Bar
Displays the number of icons in the directory or file and the number currently selected.



Directory List Box
Lets you change the current directory. If Auto-Refresh is on, the view window will be 
automatically updated.



File List Box
Lists all the files in the current directory which match the pattern in the file pattern 
selector (above the file list box). Double-clicking on a file will cause Icon Vacuum to 
search the file for icons and display them in the view window.

See Also
Viewing Imbedded Icons



Icon View Window
Displays the icons in the current directory which match the icon filter, or displays a file's 
imbedded icons. If viewing imbedded icons, Shift-F5 will refresh the view window. 
Pressing F5 will update the view window to show icon files.

See Also
Viewing Icon Names
Selecting Icons
Viewing Icon Files
Viewing Imbedded Icons



Copy Button
Copies the currently selected icon(s) to the destination directory.

See Also
File Operations



Move Button
Moves the currently selected icon(s) to the destination directory.

See Also
File Operations



Delete Button
Deletes the currently selected icons.

See Also
File Operations



Rename Button
Prompts you to enter the new name for the currently selected icon.

See Also
File Operations



Copy to Clipboard Button
Copies the last icon you selected into the clipboard. You can then paste the icon into 
another program, such as Paintbrush.



Run Icon Editor Button
Copies the currently selected icon to the Windows clipboard and then runs the default 
icon editor.

See Also
Choosing and Running an Icon Editor



Choose Icon Editor Button
Promps you to enter a new path for the default icon editor.

See Also
Choosing and Running an Icon Editor



Vacuum Button
"Vacuums" the currently selected icons. New icons are created in the destination 
directory. This button is only available while viewing imbedded icons.

See Also
"Vacuuming" Imbedded Icons
Viewing Imbedded Icons



Select All Button
Selects all icons in the current directory or file matching the icon filter, regardless of 
whether they are currently visible in the view window. This button is disabled if all the 
icons are selected.

See Also
Selecting Icons



Deselect All Button
Deselects all icons in the current directory or file matching the icon filter, regardless of 
whether they are currently visible in the view window. This button is disabled if none of 
the icons are selected.

See Also
Selecting Icons



 File Menu Commands

Copy (F8)
Copies the currently selected icon(s) to the destination directory.

Move (F7)
Moves the currently selected icon(s) to the destination directory.

Delete
Deletes the currently selected icons.

Rename
Prompts you to enter the new name for the currently selected icon.

Copy to Clipboard (CTRL+C)
Copies the last icon you selected into the clipboard. You can then paste the icon into 
another program, such as Paintbrush.

Icon Editor... (CTRL+I)
Promps you to enter a new path for the default icon editor.

Magnify Icon... (CTRL+G)
Magnifies the last icon you selected in a magnification window. You can resize the 
window to any size, and clicking the window will restore it to its default dimensions.

Refresh Directory (F5)
Causes the view window to refresh and display all icon files in the current directory which
match the icon filter. 

Refresh File (SHIFT+ F5)
Only available while viewing imbedded icons. Causes the view window to refresh and 
display all imbedded icons. Presently is of no real use.

Exit (ALT+F4)
Quits Icon Vacuum. If user configuration has changed, Icon Vacuum will ask you if you 
want to save the new settings.

See Also
Options Menu Commands
Help Menu Commands



 Options Menu Commands

Default Icon Editor...
Prompts you to enter a new path for the default icon editor.

Destination Directory...
Brings up the Destination Directory dialog box, which allows you to select a new 
destination directory graphically.

Icon Filter...
Prompts you to enter a new file pattern, (i.e. H*.ICO or VB???.ICO) which will restrict the 
icon files displayed in the view window. Icon Vacuum assumes an ICO extension.

Alphabetical Sort
If this item is checked, icon files will be displayed in alphabetical order, according to 
filename and extention. If unchecked, icons are displayed by their order on disk. 
Alphabetical sorting requires slightly more time, but the difference is hardly noticable on 
most machines.

Auto-Refresh (CTRL+R)
When this item is selected, the view window will be automatically updated whenever the 
current directory is changed. Otherwise, the user has to select Refresh Directory in the 
File menu to get the view window to update.

Find Less Icons Faster
Icon Vacuum will quickly find most but not all icons (Windows 3.1 only).

Find More Icons Slower
Icon Vacuum will slowly find virtually every icon (and even some non-icon bitmaps).

Save Configuration (CTRL+S)
Saves the current dimensions of the Icon Vacuum window, the default icon editor, and 
the settings for Auto-Refresh, Alphabetical Sort, and, for Windows 3.1 users, the 
method of icon searching in ICONVAC.INI.

See Also
File Menu Commands
Help Menu Commands



 Help Menu Commands
Index (F1)

Opens this help file and displays the Table of Contents

Commands
Opens this help file and displays the Icon Vacuum window.

How To Use Help
Opens the Windows help file on How to Use Help.

Register...
Opens the registration input box, where registered users can enter their name and 
registration numbers.

About Icon Vacuum...
Open the About Icon Vacuum dialog box, which contains copyright and registration 
information.

See Also
File Menu Commands
Options Menu Commands




